[Solved] WordPress - Reset Password Fails - "Your password reset link appears to be invalid."

Discussion in 'Third-party applications' started by LetMeRegister, Dec 18, 2020.

  1. Hi all,

    It would seem its a day for login problems for me... even this forum gave me no end of problems, looks like its half-registered me, but not enough to allow me to complete it or reset anything... hence the stupid display name on this one...born from frustration.


    So, WordPress, I have it installed on my hosted site and all was well many months ago when I last logged in to it - absolutely no problems at all, and then there is today...

    Tried to login, LastPass kindly populated the fields for me (from my previous successful logins in the past) and I was told the password was incorrect etc.

    Tried again, no joy. Decided to use the Reset Password functionality.

    After some delay I received the email notification. Entered a new password, no error but equally nothing seemed to happen. I was still unable to log in with the now new details.

    Tried the Reset Password process a few more times, every time now it just states that the "key is invalid" and I can't do anything.

    I feel like I am an utter dead end with this, its just going round in circles.

    The only changes I am aware of since my previous successful logins were things like the WordPress install getting automatically updated, and possibly, but I'm not certain, the PHP version (can't honestly remember, its been ages since I've used this)...

    I need to be able to login, but the built in functionality isn't working. I have consider just wiping the app and hoping that the backup of the data would get me back up on my feet again, but this feels like a sledge hammer approach that will invariably be frought with problems and waste even more of my time.

    I've searched online and I've found a couple of articles that mention about people with a similiar issue and the cause perhaps being "caching" on the server. This is perhaps something that might have changed without my knowledge on this hosted platform, but I do not see any options within the Control Panel to set/change anything.

    I'm really hoping that, after the painful morning with both WordPress and this forum, someone may have had the same problem and be able to just say "This is this problem, do this, its fixed" and I will invariably be in their debt for ever :)

    Thanks in advance for any help.

    Kind regards

    a.k.a. LetMeRegister! :D
    Last edited: Dec 18, 2020
  2. Just an update...

    Dmitri from WinHost support was absolutely fantastic... I got an email response really quickly to my support ticket and he noted that the Database had effectively run out of space.... he increased the limit and *boom*, I can log in again.

    Not sure whether my experience will help anyone else with a similar problem, but hopefuly, and a massive shout out to Dmitri, I am very grateful :)
    Elshadriel likes this.

Share This Page