Server Error in '/' Application

Discussion in 'Site Programming, Development and Design' started by fahad, Feb 2, 2011.

  1. Hi There

    I'm trying to publish my website designed by ASP.net , but I keep get This error


    Server Error in '/' Application.

    Runtime Error

    Description: An application error occurred on the server. The current custom error settings for this application prevent the details of the application error from being viewed remotely (for security reasons). It could, however, be viewed by browsers running on the local server machine.

    Details: To enable the details of this specific error message to be viewable on remote machines, please create a <customErrors> tag within a "web.config" configuration file located in the root directory of the current web application. This <customErrors> tag should then have its "mode" attribute set to "Off".


    <!-- Web.Config Configuration File -->

    <configuration>
    <system.web>
    <customErrors mode="Off"/>
    </system.web>
    </configuration>

    Notes: The current error page you are seeing can be replaced by a custom error page by modifying the "defaultRedirect" attribute of the application's <customErrors> configuration tag to point to a custom error page URL.


    <!-- Web.Config Configuration File -->

    <configuration>
    <system.web>
    <customErrors mode="RemoteOnly" defaultRedirect="mycustompage.htm"/>
    </system.web>
    </configuration>



    I already edit my web.config file but with no luck
     
  2. Web.Config

    Hi fahad,

    Can you please make sure that in your web.config you have the following section:

    <customErrors mode="Off" />

    That should be under the System.Web element as shown in the stripped down example below.

    <configuration>
    <system.web>
    <customErrors mode="Off" />
    </system.web>
    </configuration

    Also, make sure that the mode has a capital 'O' in 'Off' as it is case sensitive.

    Then publish the new web.config to Winhost and you should be able to see the real error that stopping you.


    For more info about the CustomErrors section of the Web.Config, see the following link:
    http://msdn.microsoft.com/en-us/library/h0hfz6fc.aspx

    Cheers mate.
     
    Last edited by a moderator: Oct 14, 2015
  3. Hello my friend

    I already did , still get the same error .

    i spend 4 days now on this issue and tried every things .

    Cheers mate.
     
  4. Would you be able to show me your web.config so I can take a look?

    Also, is this a sub-site or is it supposed to work from the root of your domain?

    Another option is that you could email yourself the exception by adding some email code to the Application_Error method in the global.asax file. That wouldn't solve your current issue but it would show you the real error.

    Cheers.
     
  5. Attached Files:

    • Web.zip
      File size:
      3.7 KB
      Views:
      279
  6. Ray

    Ray

    You haven't turned off your custom error. If you see this error message...

    Server Error in '/' Application.

    Runtime Error...

    <!-- Web.Config Configuration File -->

    <configuration>
    <system.web>
    <customErrors mode="Off"/>
    </system.web>
    </configuration>

    ...it specifically means you haven't turned it off even it you think you turned it off. This is what you have in your web.config file.


    <customErrors mode="RemoteOnly" defaultRedirect="Applications/ShowApplicationsPage.html">

    You will need to change the line customErrors mode="Off"....

    We will not be able to solve the problem if we do not see the true error message.
     
  7. Hi again

    I copied my all files to the root directory and new message appeared

    INTERNAL SERVER ERROR

    The requested web page either has an error or does not exist.

    Please contact your system administrator or customer support.

    is there any clue ?
     
  8. Ray

    Ray

  9. Like what Ray said, your CustomeErrors is still set to RemoteOnly..

    <!-- from your web.config file -->
    <customErrors mode="RemoteOnly" defaultRedirect="Applications/ShowApplicationsPage.html">
    <error statusCode="404" redirect="Shared/Internal_Server_Error.html" />
    <error statusCode="500" redirect="Shared/Internal_Server_Error.html" />
    </customErrors>

    you need to replace that with this...

    <!-- remote errors off -->
    <customErrors mode="Off" defaultRedirect="Applications/ShowApplicationsPage.html">
    <error statusCode="404" redirect="Shared/Internal_Server_Error.html" />
    <error statusCode="500" redirect="Shared/Internal_Server_Error.html" />
    </customErrors>

    If you are using a sub directory to host the site, it has to be converted to an application (you use the Application Starting Point menu item in Winhost Control Panel). Otherwise it will be using the CustomErrors section in the web.config of the root site.

    Cheers.
     
    Last edited by a moderator: Oct 14, 2015
  10. rum

    rum Winhost Staff

    The error message suggests that your application is running under insufficient trust level. Try setting the trust level to full. Please see this KB article for the instructions on how to do that.
     
    Last edited by a moderator: Oct 14, 2015
  11. Thanks I think that i'm nearly solve this problem , but i couldn't find the trust config line in web config file

    can you please check for me , im sorry guyz i know its lot of Q ,but i need to publish my site ASAP.
     
    Last edited by a moderator: Oct 14, 2015
  12. rum

    rum Winhost Staff

    For the security reason, I removed your web.config attachment because anyone can download and see your site configurations. If you cannot see trust config entry in you web config, then it has never been added to it, therefore the trust level of your account is set to medium. Please open your web.config file with a text editor, find <system.web> tag, and add <trust level="Full" /> immediately after it.
     
  13. Thanks guyz , its working ... working

    really best support team ever
     

Share This Page