Need help on Intelligencia URL Rewriter running in winhost

Discussion in 'General troubleshooting' started by Kaihatsusha, Oct 6, 2009.

  1. I'm currently deploying a website that requires the use of Intelligencia URL Rewriter. While this works on my local (IIS 7.0), I'm really clueless on how to make it work on Winhost server. I would really appreciate help.
     
    Last edited by a moderator: Oct 14, 2015
  2. I tried URL Rewriter 2.0 (Intelligencia) and UrlRewriting.NET and both doesn't seem to work, both works on local anyway. If both of these are not supported as a URL rewriting module, then please at least tell me the URL rewriting that works, as written on the features that URL Rewriting is supported.
     
  3. curtis

    curtis Winhost Staff

    we support the microsoft url rewrite module.
     
  4. Now using Microsoft's URL Rewrite module

    I'm now using it and doing a redirect test.
    I'm also adding the rules thru IIS7 Manager.
    Still, no luck on it.

    I get this error.

    HTTP Error 404.0 - Not Found
    The resource you are looking for has been removed, had its name changed, or is temporarily unavailable.

    But those are just a matter of querystrings.
    Do I need to activate something before I proceed on adding rules?
     
  5. Ray

    Ray

  6. I have read them, and even watched the video walkthrough.
    I know I've done each steps properly, since I'm just doing a simple rewrite
    for a page that accepts 1 querystring variable.

    I'm doing basic URL rewriting so, I'm surprised that it always end up in a 404.

    any ideas? am I missing something?
     
  7. Ray

    Ray

    Can you give us a URL to test? Tell us exactly what you expect to happen.
     
  8. ok.. here it is

    http://clcdisco.w01.Winhost.com/

    or
    http://clcdisco.w01.Winhost.com/default.aspx

    displays english.

    http://clcdisco.w01.Winhost.com/?lang=J

    or

    http://clcdisco.w01.Winhost.com/default.aspx?lang=J

    displays japanese.

    so, I added a rewrite rule

    here is the webconfig file, this file is altered by IIS7 Manager (when I added the rewrite rule)

    =====================
    <?xml version="1.0" encoding="UTF-8"?>
    <!--
    Note: As an alternative to hand editing this file you can use the
    web admin tool to configure settings for your application. Use
    the Website->Asp.Net Configuration option in Visual Studio.
    A full list of settings and comments can be found in
    machine.config.comments usually located in
    \Windows\Microsoft.Net\Framework\v2.x\Config
    -->
    <configuration>

    <configSections>

    <!--<section name="rewriter"
    requirePermission="false"
    type="Intelligencia.UrlRewriter.Configuration.RewriterConfigurationSectionHandler, Intelligencia.UrlRewriter" />-->

    </configSections>

    <appSettings />
    <connectionStrings />

    <system.web>
    <!--
    Set compilation debug="true" to insert debugging
    symbols into the compiled page. Because this
    affects performance, set this value to true only
    during development.
    -->

    <!-- added -->

    <trust level="Full" />

    <compilation debug="true">
    </compilation>
    <!--
    The <authentication> section enables configuration
    of the security authentication mode used by
    ASP.NET to identify an incoming user.
    -->
    <!--<authentication mode="Windows"/>-->
    <!--
    The <customErrors> section enables configuration
    of what to do if/when an unhandled error occurs
    during the execution of a request. Specifically,
    it enables developers to configure html error pages
    to be displayed in place of a error stack trace.

    <customErrors mode="RemoteOnly" defaultRedirect="GenericErrorPage.htm">
    <error statusCode="403" redirect="NoAccess.htm" />
    <error statusCode="404" redirect="FileNotFound.htm" />
    </customErrors>

    <customErrors mode="RemoteOnly" defaultRedirect="/">
    <error statusCode="403" redirect="/" />
    <error statusCode="404" redirect="/" />
    </customErrors>

    -->
    <httpModules>

    </httpModules>

    </system.web>

    <system.webServer>

    <validation validateIntegratedModeConfiguration="false" />

    <modules runAllManagedModulesForAllRequests="true">

    </modules>
    <rewrite>
    <rules>
    <rule name="japan def">
    <match url="/Japanese/" />
    <action type="Rewrite" url="default.aspx?lang=J" />
    </rule>
    </rules>
    </rewrite>

    </system.webServer>

    </configuration>

    ~~~~~~~~~~~~~~~~~~

    so that it should display

    http://clcdisco.w01.Winhost.com/default.aspx?lang=J

    whenever I access

    http://clcdisco.w01.Winhost.com/Japanese/

    but i always get 404 error.
     
    Last edited by a moderator: Oct 14, 2015
  9. Try this. The URL to match should be "japanese/?$"
     
  10. Wow! Works like charm!
    uhm, can you explain a little about the url to match?

    Thank you very much.
     
  11. Ray

    Ray

    You may want to review this link. This link is a tuturial to the standard expressions that can be used.

    http://www.amk.ca/python/howto/regex/

    The expressions are basically characters and symbols that allows a specific call to a URL match to a condition you are trying to initiate.
     

Share This Page