Installing Umbraco 4.7 issues

Discussion in 'Third-party applications' started by SaintSkeeta, Mar 22, 2011.

  1. Hi,
    I've run into some issues with installing a clean version of Umbraco 4.7 on Winhost.
    I tried to follow Ben Powell's blog post but had issues seeing as the links don't work, and he was using an older version.
    Basically, the changes to web.config I needed to make to get my installation to work were:-
    - Add requirePermission="false" to each of the sections in 'configSections'
    - Change httpRuntime node under system.web to be <httpRuntime executionTimeout="9000" maxRequestLength="4096" useFullyQualifiedRedirectUrl="false" minFreeThreads="8" minLocalRequestFreeThreads="4" appRequestQueueLimit="100" />

    This finally got me through the installation process, however when I went to preview my site I get the following error:-

    Parser Error Message: Inheritance security rules violated by type: 'umbraco.presentation.templateControls.ItemDesigner'. Derived types must either match the security accessibility of the base type or be less accessible.

    Am I missing some more permission settings that I need to change? If anyone could help me with this it would be greatly appreciated.
    Last edited by a moderator: Oct 14, 2015
  2. I just realised as well that when I go to I get the Umbraco admin....however there are no content items under the Content Node. Same too with the Media section, Settings section, etc....

    This installation works fine on my local machine, with the website working, and the admin showing all content nodes. I would really appreciate any help anyone could give.
  3. Ray


    Make sure you set your trust level to Full. By default it is set to Medium. If you have not manually set it to True try doing that and let us know if you get the same error message.
  4. OK, thanks. I wasn't sure how to do that. Googling it I think I just have to add:-

    <trustLevel name="Full" policyFile="internal"/>

    to the <system.web> node in the web.config file. Is that right, or is there more to it?
  5. Nope, still no good. Maybe there is something else I need to do other than the web.config change I listed above?
    I even tried re-installing umbraco with the security level change in my web.config, but I still get the security exception message as before. Any ideas?

    Ben Powell's article mentions a 'suggested web.config' file (which no longer exists at the link. He then mentions some other sections you need to edit, which I cannot find in my web.config. Do I need any more changes to be made to the web.config file?
  6. Last edited by a moderator: Oct 14, 2015
  7. Never a waste of time! Glad you worked it out.

Share This Page