How to avoid using secondary URL in DNN site

Discussion in 'DNS/Domain names' started by Pyronaught, Aug 5, 2012.

  1. I got an email last month saying that Winhost is changing the secondary URL from to The secondary url for my site is actually, is this one going to change also? Unfortunately I am currently using the secondary url in a bunch of links I have in a DNN site because I could not get DNN to work using just the domain name for the site. I have setup in the Portal Aliases section of DNN, but when trying to actually use it I get a "resource can not be found" error.

    For example, here is a sample URL that works:

    If I change it to this, I get the error:

    Even if the new secondary url is not going to effect my site, I still want to get this fixed in case the secondary url changes in the future. If the change DOES effect my site, then I've got a serious problem with only 12 days to solve it.

    Anyway, I'm worried that the removal of the old secondary URL scheduled for Aug. 17 is going to cause my site to crash if I can't get this working.
    Last edited by a moderator: Oct 14, 2015
  2. Elshadriel

    Elshadriel Winhost Staff

    The Secondary URL will be removed, so you need to update the links in DNN, however, I'm curious as to why your main URL is not working. Have to pointed the DNS over to us already?
    Last edited by a moderator: Oct 14, 2015
  3. Yes, if you type it goes to the site but then DNN switches to using the secondary URL for all the pages. It's a DNN configuration thing, but I just can't figure out how to get it working. It would appear that all you should have to do is add to the Portal Aliases section of the Site Settings page, but I've tried that and it doesn't work. I also added the new secondary url to the alias list, but then when I use to access pages that doesn't work either. It just only works using the original secondary url for some reason no matter what aliases I have setup. I also reset the site after adding a new alias by changing/saving the web.config file so that IIS will reload the site and clear the cache, but still no luck. If I type it will also redirect to using the old secondary url the same way using does.

    Has the replacement for been setup yet or is that just something that is going to happen in the future?
    Last edited by a moderator: Oct 14, 2015
  4. Elshadriel

    Elshadriel Winhost Staff

    The replacement for is will be de-activated at a future date.
    Last edited by a moderator: Oct 14, 2015
  5. I would think if I took a functioning url such as, added as an alias in the DNN Site Settings page, recycled the application pool and then used the url it should just work. I even tried making the default alias, but that doesn't work either. I've watched videos on how to use portal aliases in DNN and they are doing the exact same thing. The only other step is setting up IIS to handle the url, but you guys have already done that as evidenced by the fact that typing in will bring up the site. It just doesn't bring it up using the version of the secondary url, but rather redirects to the version since that is setup to be the default right now. Using the version as the default results in a "page not redirecting propperly" error.
    Last edited by a moderator: Oct 14, 2015
  6. For DNN configuration questions you might be better served looking for an answer in their forums.
  7. I've been doing that too, but their forum is very unresponsive and this situation doesn't appear to have ever been discussed there in the past. I was just throwing it out here in case it was an IIS configuration issue instead of DNN, since setting up a portal alias requires changes in both IIS and DNN.
  8. I got this figured out finally (with no help from DNN forum). There is a web.config file in the root directory which contains some special url rewrite rules for IIS7 compatibility and the secondary url was hard coded into that. So the default alias can not be changed without also changing it in this file.
  9. Ah, makes sense. Glad you worked it out.

Share This Page