Generate Script Wizard - Will Not Complete

Discussion in 'General troubleshooting' started by rvooys, Feb 16, 2010.

  1. I was able to make back-ups of my data, bi-weekly using the Generate Scripts Wizard.

    As I tried to load up the last back-up it failed.

    I got errors on the load, and only 1/12 of my tables.

    So I tried to generate the scripts again, and now it hangs up and eventualy fails on the last item in database.

    I tried exporting each item as it's own file to determine exactly where an issue happens and it happens on the second table in my database.

    Any ideas?
  2. Ray


    What is the error message? Post the complete and exact error message on this thread.
  3. I ran it this am, and I had no difficulties.

    File loaded with no problems either.

    If I have another problem I will post the message.

    Is there a problem when you run it while people are using it?

    Is there a way to schedule this to run, say at 11 pm each night?
  4. Ray


    There can be a problem depending on how the database is created and the relationship restrictions you imposed on it.

    You can set it to be a single user mode so only you at that time can use the database. Simply run the command...

    Alter Database [database_name] SET Single_user with rollback immediate

    Then when you are done with the script run...

    Alter Database [database_name] SET Multi_user
  5. When I tried to set it too Single User it told me I didn't have permissions.

    The I took it offline, not good, locks you right out.

    But when I ran the generate scripts, before I tried any of the above, I get

    * Internal Conenction fatal error. ("
  6. Ray


    Did you type Use [type your database name here without the brackets]

    You can bring your database back online.

    Go to MS DOS and use the sqcmd command

    c:\>sqlcmd -S [sql server] -U [db username] -P [db password]
    then type

    alter database [database name] set online

    then type...

  7. Ok, I ran the command on the DB_2589_BlackHeart database and it locked me out. I couldn't get in from the SSMS, or the command line.

    I just tried the command line when it was back up, and all works fine.

    I will try next time I can take the database down for a couple hours, but I did this during production time, bad bad.
  8. I am again having this issue.

    Is there a size limitation to using the generate scripts?
  9. Ray


    Last edited by a moderator: Oct 14, 2015

Share This Page