FTP Publish from VS 2013 now not working

Discussion in 'FTP' started by Craigsn, Mar 13, 2014.

  1. I've been publishing directly from VS 2013 since I started here, and then today, I tried to publish a new build, and it fails with the following:

    5>------ Publish started: Project: <myproject>.Web, Configuration: Rel_IRLogger Any CPU ------
    5>Connecting to ftp://<mysite.com>/IRLogger...
    5>Transformed Web.config using C:\<myproject>\<myproject>.Web\Web.Rel_IRLogger.config into obj\Rel_IRLogger\TransformWebConfig\transformed\Web.config.
    5>Copying all files to temporary location below for package/publish:
    5>Deleting existing files...
    5>An error occured trying to enumerate the contents of folder ''. Cannot connect with active FTP. Please try using passive FTP.
    5>Site was published successfully ftp://<mysite.com>/IRLogger
    ========== Build: 4 succeeded, 0 failed, 0 up-to-date, 0 skipped ==========
    ========== Publish: 0 succeeded, 1 failed, 0 skipped ==========

    But I when I validate the connection, everything works fine. When I use FileZilla FTP, that connection works fine.

    So I'm at a loss of what to try next. Suggestions?
  2. Elshadriel

    Elshadriel Winhost Staff

    There should be an option to check/un-check that in the FTP settings.
    Michael likes this.
  3. That worked. Thanks for the suggestion. But what changed between 2 days ago, and today? I was using the default "Active" FTP setting fine for over a month with no problems. It would be nice to know.

  4. Elshadriel

    Elshadriel Winhost Staff

    Hi Craig,

    I honestly don't know. It might be something with Visual Studio 2013.
  5. Thanks Elshadriel. I don't think anything changed in VS2013, but maybe there was an update that did something to it. Thanks for the prompt response.

Share This Page