DNN permission issues

Discussion in 'Third-party applications' started by John102, Jun 6, 2010.

  1. Hi all,
    My first post and would like to say that I had the same problem with permissions until I tried what "JimmyZ" said about changing to medium trust and then back to full....................And voila...it worked and I no longer have permission issues:)

  2. Ray


    Yes, this is a very common problem with DNN. The error message is very misleading cause it makes you believe it is a NTFS permission issue, when in fact it is a trust level setting with the application.
  3. Permission issues

    Hi again,

    Update regarding my new install of DNN.
    The app installed but before it finished installing I got this message:

    This site is currently Unavailable
    The Active Directory Provider requires the site to be running
    under Full Trust and/or in Classic mode in IIS 7.0
    Commenting out the line:
    <add name="Authentication" type="DotNetNuke.Authentication.ActiveDirectory.HttpModules.AuthenticationModule, DotNetNuke.Authentication.ActiveDirectory" />
    in your web.config will allow you to get the site running until it meets the above requirements.

    I did as requested and the install finished.
    I did a little functionality testing (Pushed alot of buttons and what not)
    All seems to be functioning but when I checked the site event viewer logs I see alot of exceptions, most of which refer to folder access permission(Message: System.UnauthorizedAccessException: Access to the path '\Cache\Modules\' is denied.)

    Here is an example:

    AssemblyVersion: 5.4.2
    PortalID: -1
    UserID: -1
    ActiveTabID: -1
    DefaultDataProvider: DotNetNuke.Data.SqlDataProvider, DotNetNuke.SqlDataProvider
    ExceptionGUID: 01bab2ac-82c1-4401-81fd-cf11ce776751
    InnerException: Access to the path '\Cache\Modules\' is denied.
    FileLineNumber: 0
    FileColumnNumber: 0
    Method: System.IO.__Error.WinIOError
    Message: System.UnauthorizedAccessException: Access to the path '\Cache\Modules\' is denied. at System.IO.__Error.WinIOError(Int32 errorCode, String maybeFullPath) at System.IO.Directory.InternalCreateDirectory(String fullPath, String path, DirectorySecurity dirSecurity) at System.IO.Directory.CreateDirectory(String path, DirectorySecurity directorySecurity) at DotNetNuke.Services.ModuleCache.FileProvider.GetCacheFolder(Int32 portalId) at DotNetNuke.Services.ModuleCache.FileProvider.PurgeExpiredItems(Int32 portalId) at DotNetNuke.Services.ModuleCache.PurgeModuleCache.DoWork()
    Server Name: W03

    and regarding the change I had to make to the config file to complete install, when I went back to look again the line was gone from the config file!!!!

    I have reinstalled a couple of times and checked, checked and rechecked the different settings I can adjust on IIS7 manager.

    Anyway if anyone can advise how to solve this I'd be grateful. I'd like to get it sorted now rather than later....



    PS I have both root and install directories set to full permission
  4. Ray


    Let me get this straight, when you comment out the line...

    <add name="Authentication" type="DotNetNuke.Authentication.ActiveDirectory.Ht tpModules.AuthenticationModule, DotNetNuke.Authentication.ActiveDirectory" />

    From your web.config file the changes don't take place. Remember if you upload a new web.config file you need to make sure that the changes are also set, else it will over ride the old settings.

    This authentication type cannot work on our shared hosting system. We do not support ActiveDirectory this is a stand alone server. If you are going to do authentication it will have to be through Forms authentication using the ASP.Net Membership/Roles provider.
  5. Hi again,

    when I commented out the line it worked fine, but when I checked it again later the line seems to have disapeared vs being commented out.(I just checked again as I'm writing and the VS search function says its not there)

    and as I said I have multiple exceptions in the DNN logs.....

  6. Ray


    The server itself does not change your web.config file. You are somehow over riding it.

Share This Page