Can't delete folders/files in FTP (or update plugins in WP)

Discussion in 'FTP' started by stevecoom, Oct 12, 2014.

  1. Hi

    I have a number of websites at Winhost . A couple are on wordpress. Until recently (last month) I had no problems with either site.
    Now one site is still working fine but the other I have issues deleting files/folders.
    I have been using the automatic update for plugins in wordpress- its been working fine.
    However I now get an error when trying to install a plugin or delete a plugin (from within wordpress). Thinking it may work via FTP I attempted to try a manual update - no, it fell over.
    Exmple of error messages:-
    "Plugin could not be deleted due to an error: Could not fully remove the plugin(s) safe-redirect-manager/safe-redirect-manager.php."
    I try to remove the file via FTP - fail again with the message
    "Request denied.
    Verify that the file or folder exists and that you have the necessary permissions on the server to perform the requested operation"
    COMMAND:> DELE ajax.php
    550 Access is denied.
    ERROR:> Requested action not taken (e.g., file or directory not found, no access).

    I have been able to MOVE the whole website to a temporary folder - but still cannot delete any files even under the temporary folder. I can upload new files as long as i am not overwriting files.
    I can even rename any file , but even after renaming i cannot delete the file ....

    Any ideas ?
    Last edited: Oct 12, 2014
  2. ComputerMan

    ComputerMan Winhost Staff

    This can sometimes happen when your site has a hidden file and FileZilla isn't set to show hidden files. Then when you try to delete the subdirectory the contains the hidden file you will get that error message.

    You can force FileZilla to show hidden files by opening FileZilla. Click on "Server" on the top and select "Force Showing Hidden Files."

    This issue will also happen if the site is currently using the file on the server. To clear this you should recycle the application pool through the control panel.

    To do this login to the control panel. Click on the "Sites" tab at the top.

    Click on "Manage" next to the site.

    On the next page click on the icon "Recycle App Pool" box.

    Click on "Recycle App Pool".

    Then try to delete the files.

    If you're still having an issue. Please open a ticket through the support portal and tell us what exact directory/file it is you're trying to delete so we can try do recreate the issue on our end. Also, confirm that you will not hold us liable for any data loss that may occur when we try to delete the file.
    Last edited by a moderator: Oct 14, 2015
  3. Hi
    Thanks for the response
    1. I have recycled the app pool many times
    2. Turned on hidden file filter (CuteFTPpro) - nothing found
    3. I can't see file/folder permissions (is that a Winhost setting ?) so cant confirm the file/folder settings but support have confirmed that permissions etc are correct - which i would expect to be since 2-3 weeks ago i didn't have any problem removing files
    4. If i upload files I can delete those no problem - so i think your comment " site is currently using the file on the server." is correct since these files are not being used by the site - BUT ....recycling the app pool doesn't seem to clear that connection
    5. Even moving the whole site to a sub folder (and taking the site down as a by-product) doesn't seem to release the files

    I appreciate that you guys could probably remove the files - which is great ... but since i want to manage the site myself / upgrade plugins / upgrade the site when i am ready and want to ... its a bit frustrating having to turn to a 3rd party to sort it out!

    Last edited by a moderator: Oct 14, 2015
  4. Did this ever get solved? Same problem here.
  5. Yes .... but nothing I did made a difference and then one day it worked .......... sorry I didn't find a solution, but i am now hosting WP sites elsewhere due to the initial issues and the fact its not that fast for me (based in the UK).
  6. You can use longpathtool program to solve this issue. this tool is very useful to solve this issue.

Share This Page