in subfolder

Discussion in 'Third-party applications' started by Stevercakes, Dec 4, 2009.

  1. I've been trying to set up in a subfolder of my website.
    I get it running and everything but as soon as I make an update to the settings of the blog and then go back to the front page. What gets outputted is mumbo jumbo and the only way that I know how to fix it, is to reupload the entire app_data folder.

    Here's a copy paste of what gets outputted after updating:


    and so on and so on.

    The weird thing is that if I leave everything on default and add an entry. It works fine.

    I can add a user but I can't update the user.

    I was just wondering if anybody else has ran into this problem. I tried searching all over the official site but I can't find anything.

    I've given the app_data folder 777 permissions. I have my application running at high trust. I have the /blog/ folder set as an application.

    If you want to see what it currently looks like. View the mess of a blog
  2. Ray


    I don't think its the app_data folder that is the cause but some other file that calls on the app_data folder when you alter or modify the settings.
    It maybe that one of the files may have gotten corrupted during the initial upload.

    Try this. Create another subfolder 'blog2' and set it as an application starting point. Upload a new application to that folder and test it out. If it works and it fixed the problem then my theory is correct and all you need to do is reupload a new application.

    This maybe an easier way to go rather then hunting down exactly what file is getting corrupted.
  3. I tried creating a new folder called /blogTest/ and redownloaded and uploaded it.
    It starts up fine as the previous folder did. Same thing though when I go and update any settings for the blog. It just outputs the same random characters and what not.

    Downloaded their 1.5 stable release msdeploy.

    I'm at a loss. Maybe i'll try a different blog.
  4. I ended up just having the blog being hosted through wordpress. Easier and less stressful than tinkering around with trying to get it working.
  5. Ray


    That always works. I just installed 1.5 on my account and I could replicate what you where getting. If you can give me the steps on what you did to get that problem with your blogengine and I'll try to replicate it on my end.
  6. I had this problem when I first installed BE. I unchecked "Enable HTTP compression" and "Trim stylesheets" under Settings - Advanced Settings and refreshed the page. That cleared it up. I think this is a BE bug - I've seen it on other hosts.

    I have to leave "Trim stylesheets" unchecked - if I check it, I don't get any stylesheets. I think this is a conflict with BE and IIS7.

  7. Ray


    I thought I saw something like this before but I couldn't find any documentation for it. You wouldn't happen to have a posting from BlogEngine that may shed some light on this bug?
  8. Take a look at this thread:

    Maybe more interestingly, I discovered my gibberish problem was more mundane. I had a compile error in my MasterPage. It was something simple - I think I had two <body> tags or something. I fixed that and the gibberish went away. It's not a very satisfying situation, but that seemed to have been the "real" problem in my case.

  9. Ray


    Tom, Thanks again.
  10. Thanks for the information, i'll have to remember this for future uses of BlogEngine.

Share This Page