BlogEngine.Net admin CSS problem

Discussion in 'Third-party applications' started by Nikola Tesla, Apr 30, 2013.

  1. I have installed into subfolder /blogengine. Blog works, I can log as an admin but in admin dashboard or other configuration pages it seems that css is not loading. Can you please help with this matter?
    Thank you.
  2. Elshadriel

    Elshadriel Winhost Staff

    Try un-marking it as an Application Starting Point in the Control Panel.
  3. Did that and nothing happens but error:

    Server Error in '/' Application.
    Configuration Error
    Description: An error occurred during the processing of a configuration file required to service this request. Please review the specific error details below and modify your configuration file appropriately.
    Parser Error Message: It is an error to use a section registered as allowDefinition='MachineToApplication' beyond application level.  This error can be caused by a virtual directory not being configured as an application in IIS.
    Source Error:
    Line 8:    </configSections>
    Line 9:    <BlogEngine>
    Line 10:     <blogProvider defaultProvider="XmlBlogProvider" fileStoreProvider="XmlBlogProvider">
    Line 11:       <providers>
    Line 12:         <add description="Xml Blog Provider" name="XmlBlogProvider" type="BlogEngine.Core.Providers.XmlBlogProvider, BlogEngine.Core"/>
    Source File: E:\web\neskovic\blogengine\web.config    Line: 10
    Show Additional Configuration Errors:
    Version Information: Microsoft .NET Framework Version:4.0.30319; ASP.NET Version:4.0.30319.272 
    I've uploaded version of BlogEngine.Net to another folder and it works without errors in admin pages. So do something with your installation of BlogEngine.Net v2.7.0.0.

    And now I can't change theme in the Found that it needs write permission on theme folder. Why is this so complicated? Can you help?
  4. Elshadriel

    Elshadriel Winhost Staff

    The installation tool works fine. The error that you are receiving means the sub-directory needs to be marked as an Application Starting Point. You are running into a web.config inheritance problem. Sometimes, un-marking will fix it (easy fix). If you run into further errors, then you may need to disable child inheritance in some of the settings:

    I also checked your account and the permissions are fine. You might need to enable 'Full' trust though:
    Last edited by a moderator: Oct 14, 2015

Share This Page