Wordpress install not loading index.php

Discussion in 'Third-party applications' started by SL1Dig, Oct 6, 2010.

  1. I have installed wordpress on my site and connected everything up just fine -- when I go to my /blog page it does not automatically load the index.php page -- instead I get a directory listing of all of the php files.

    How do I direct the site to automatically recognize index.html and index.php as default pages?
  2. Ray


    Last edited by a moderator: Oct 14, 2015
  3. thank you for your quick response. I update my local iis from 6 to 7 then attempted to connect. After entering my username and password I get the following error:

    Could not connect to specified computer

    Details: Unable to connect to the remote server

    in looking this up on the iis forums, most users have to change their server setting to allow the connection. What should I do at this point?
  4. not sure if this is relevant or not -- I attempted go directly to the address 'servername/domainname' and got a 404 -- not sure if something would normally exist there or not.
  5. Ray


    The error can mean multiple things. First make sure you are choosing Connect to Site and not Connect to Server.

    Make sure you read the kb article carefully and follow its instructions. Many people do not read the KB article or quickly scan through it missing a lot of crucial details.
  6. I did select connect to Site.

    I have done a fair amount of tech support before, so I have learned to go back and slowly re-read instructions when I have a problem. I followed the instructions exactly and double checked that myself from the beginning. Originally, I had a problem going through our proxy server initially, but I was able to clean that up on our end.

    there is no way to add this info through the control panel?
  7. Ray


    I'm going to need you to show me some screenshots of your IIS 7 Manager. Like I said the error means a lot of things and I really cannot troubleshoot the problem with just the error message.
  8. No, sorry. When IIS 7 Manager came out we decided to point users in that direction rather than recreating a lot of functions in Control Panel that were available in IIS Manager.

    Connecting the first time can take a bit of patience, but once you start using it I think you'll like it.
  9. ray -- any info you need I will get to you. The screen shot would be pretty plain though as I typed the entire thing out :)

    the screens before it are very very simple and say exactly what the tutorial tells me to put in. I can post that info if you want -- I don't think there would be a problem with that -- although I wouldn't like to put my un/pass in. I had only just installed iis 7 so the settings are all default.
  10. Installing it at home worked -- must have been a corporate firewall issue I guess...

    Thank you both for your help.
  11. Ray


    The was the next probable cause. FYI IIS 7 Manager uses port 8172 as the port to remotely call an IIS 7 server.
  12. Hey, at least you got it working, cool.
  13. I installed Wordpress last night and this tip worked for me.
  14. Cool! That's why these forums are great. Everyone can benefit from the hashing out of one person's problem.

Share This Page