WebDeploy - Strange issue

Discussion in 'General troubleshooting' started by jamesedwards0579, Jul 3, 2018.

  1. I just signed up with WINHOST this past week.

    I was able to quickly deploy my ASP.Net MVC5 application using VS2013 WebDeploy. Everything worked perfectly. My app uses EF6 and the DB was created perfectly with all migrations applied.

    When I launch the app and login to the application I have a bootstrap session timeout plugin. This plugin pops up a modal message to the user and then logs them out within 30 seconds.

    The current version of my code that is checked into source control and on my desktop has this session timeout at 15 mins. However the version that is running on the WINHOST site has session timeout at 1 minute. This is code that I was testing about 2 months ago. It is NOT part of my current code base.

    Even today when I run the app locally on my desktop, the session timeout occurs after 15 minutes.

    I have completely deleted the DB and virtual directory on the hosted site. I have deployed again using WebDeploy and FTP. No matter what I do, I keep getting the session warning at 1 minute on the hosted version of my application.

    Just before I wrote this message, I deleted everything on the hosted site. Created new virtual directory and deployed the latest code and still the 1 minute session timeout is happening.

    Has anyone run into something like this before and have any idea what could be causing this issue?

  2. Elshadriel

    Elshadriel Winhost Staff

    Maybe you're running into a CPU/memory issue? The application pool would recycle, thus creating what seems like a session timeout of 1 minute. You could always open up a support ticket and have us check the logs.

Share This Page