WCF support

Discussion in 'Site Programming, Development and Design' started by japinthebox, Jan 8, 2010.

  1. I set the CPU Limit property to 75000 and the Private Memory Limit and Virtual Memory Limit to 102,400 in both the default settings as well as the settings for my two pools.

    Still works fine on my machine.
  2. Ray


    Not exactly sure where else to go from here. All I can say is when I pull up your test link and monitored the server, I can see in the task manager that your application pools starts reaching 100 MB. Then it disappears as our system recycles it. The .Net framework version we have on our system is 3.5.
  3. you might want to try specifying a maxReceivedMessagesize. I have had this error in the past on WCF services if the amount of data being returned was larger that the specified size. Default is ~62000, and it will go > 2000000000. might be worth a shot, though I have no experience using Linq with WCF.
  4. Nope, no luck.
  5. Ray


    What database are you using when you test it on your testing server? Can you make a simple WCF application what calls on a single table? Maybe its not the application that is recycling the application pool but the data you are pulling?
  6. I'm using the SQL Server that's on the host. The test code on the page is pulling just a single table with a Linq to SQL ORM that has just one table. The table has just one column, called ContactID, and I'm only sending one row at a time over WCF.
  7. Interested to see how this pans out. I'll be running a WCF service for my site soon as well. But if it turns out to be problematic, I can always just run provider DLLs instead. Hope you get it worked out!
  8. Ray


    I don't think the main issue is with WCF but the connection to the SQL database and how it is being posted back. Maybe more with LINQ then anything else, but honestly I haven't seen this before so I'm at a lost. So if anyone has ever seen this and found some alternatives, please post it here.
  9. I've ruled out the SQL connection.

    The worst part is that nothing shows up in the WCF trace logs either...
  10. Old thread this one but it has the same error as one I've just trapped (although you could be getting the error for far too many reasons).

    The error reported was "‘An error occurred while receiving the HTTP response to http://localhost:8731/Design_Time_Ad...rary/Service1/. This could be due to the service endpoint binding not using the HTTP protocol. This could also be due to an HTTP request context being aborted by the server (possibly due to the service shutting down).’"

    The commented out line in this code caused my issue and it looks like I'll need to use arrays instead of list of's:

    Using poSqlDataReader As SqlDataReader = cmd.ExecuteReader(CommandBehavior.CloseConnection)
    While poSqlDataReader.Read()

    Dim psSupplierCode As String = poSqlDataReader.GetString(poSqlDataReader.GetOrdinal("SupplierCode"))
    Dim psSupplierName As String = poSqlDataReader.GetString(poSqlDataReader.GetOrdinal("SupplierName"))

    'The following line fails on Winhost
    'poSupplierList.Add(New Supplier(psSupplierCode, psSupplierName))

    'Try other new method
    'Dim poSupplier As New Supplier
    'poSupplier.SupplierCode = psSupplierCode
    'poSupplier.SupplierName = psSupplierName
    ''The following line fails on Winhost

    End While


    End Using

    Almost had to get my shotgun out for that one. Arrays suck and lists rule. I'm 100% getting the data. And a list of 0 items can be dimmed and returned ok.

    Can work around it (would rather it just worked though :()
    Last edited by a moderator: Oct 14, 2015

Share This Page