Unable To Connect To Site In IIS 7 Remote Manager

Discussion in 'Site Programming, Development and Design' started by Grandizer, Mar 9, 2011.

  1. Hello,

    I am attempting to push my site and make some modifications to it. Via the control and documentation I found out I had to download the IIS 7 Remote Manager. No problem. I am attempting to Connect to a Site and entering the data the document (http://support.Winhost.com/KB/a628/using-the-microsoft-iis-70-manager.aspx) says and I get the same error the guy in the following article did:


    "Could not connect to the specified computer. Details: The remote server returned an error (401) Unauthorized."

    I noticed in the above article that what seemed to "solve" his problem was that it wanted "mysiteUSERNAME" which seemed odd to me. I tried with and without Username (as my actual FTP user name) and no luck.

    What am I missing here?
    Last edited by a moderator: Oct 14, 2015
  2. Ray


    Last edited by a moderator: Oct 14, 2015
  3. I apoligize, I misspoke. I am not actually PUSHING my site via IIS. I am using and have successfully used Smart FTP. What I need to do is setup a folder as a second "application" via the IIS Manager. This is needed because my site is using MVC 3 (and actually is running!) and a folder (Blog) will be the blog "application" using BlogEngine.net. I have set this up locally and it works great. I just need the IIS 7 Remote Manager to change a few settings and THAT is where I am having the problems. Just can't connect to my site via IIS Manager.

    Please and thank you with help for this?
  4. Ray


    Last edited by a moderator: Oct 14, 2015
  5. Thank you for the reply. But YES, I have already done that. I now need to go into IIS and tell it that needs to be an .Net 2.0 application instead of the sites 4.0 setup.

    So my question still is, WHY do I get the following error and how can I connect to my site via IIS Remote Manager? I am doing everything by the suggested KB article and I always get:

    "Could not connect to the specified computer.
    Details: The remove server returned an error: (401) Unauthorized."

    I am not sure why it is saying Unauthorized. I put in the credentials of:

    The login of my FTP says it is the same as my control panel login so I am using that.

    I have noticed that if I try to FTP in and use the original "screami1" login, that password and login combo doesn't get me in. I can FTP to my site using the new "screami1_admin" with that same password and it works. But that combo doesn't work in the IIS manager.

    This is damn frustrating.
    Last edited by a moderator: Oct 14, 2015
  6. Ray


    It sounds like you are inputting an incorrect FTP login password. Log into your Winhost control panel and go to the Site Info Manager for screamingmonks.com. If you look to your left you will see information about your account and the password to "screami1". Look for the row FTP Password and click Update. This will allow you to reset your password for this user.

    IIS 7 Manager will not be able to connect to our web server using a second FTP login. It will only work with the main FTP login which is "screami1".
    Last edited by a moderator: Oct 14, 2015
  7. That was the trick. I am not sure if I changed the main FTP user password or it happened when I created an alternate FTP user. But I changed it and was able to get in.

  8. Glad you got it working. It's a great tool.
  9. Connect to Site - no pemissiosn to manage


    Even if you connect to site using IIS manager , do you have the permissions to change the .net version from 4.0 to 2.0.

    I have a similar issue where i can connect to site and see the sites in IIS. But i cannot change the framework settings or convert to application. How can i do this.

  10. Last edited by a moderator: Oct 14, 2015
  11. I have changed the framework to 4.0 from the control panel. But how can i convert the site copied to a web application. I opted for Connect To Site option, but i can just view the site i had copied using ftp.

    When i choose the Connect to Server option i am not able to connect


Share This Page