SubDomain prompts for Authentication 401.2 Access is Denied

Discussion in 'DNS/Domain names' started by Neoh, Jan 14, 2013.

  1. I have a very basic requirement to have a staging environment for my application. I have Created the subdomain as instructed in this url:

    I have Created the \Stage subdirectory and Added Anonymous access and disabled all authentication. I have also tried with a replica of my application in the folder and deleting all contents with the same prompt.

    Why is this so difficult on this hosting provider? I've search the forum and nobody seems to have been too successful with this.

    Error message 401.2.: Unauthorized: Logon failed due to server configuration. Verify that you have permission to view this directory or page based on the credentials you supplied and the authentication methods enabled on the Web server. Contact the Web server's administrator for additional assistance.
    Last edited by a moderator: Oct 14, 2015
  2. Elshadriel

    Elshadriel Winhost Staff

  3. So based on that post, I removed my forms authentication from my Web.config and now I can access the Stage subfolder. But now there is no security on my website. I still want to enable authentication how can I do this?

    Is there a better value for deny users? Here is the troublesome entry in my root web.config

    <authentication mode="Forms">
    <forms name="MyCookie" loginUrl="Login.aspx" protection="All" timeout="90" slidingExpiration="true"></forms>
    <deny users="?" />
  4. Neoh, do you think that you could post or PM me the URL of your site so that I could take a look?
  5. Excellent Neoh, and thanks for posting your solution!

    This will help other users out for sure.

Share This Page