Problems with RSS Feed

Discussion in 'Pre-sales questions' started by Guest, Feb 17, 2010.

  1. Guest

    Guest Guest

    Hi,

    I display an RSS feed on my site using an XMLDataSource. I am unable to get it to work properly since I migrated to Winhost.

    I get this error now. (It was working fine in my previous hosting provider location)


    Access to the URL '/newsfeed/rss/rej_frontpage.xml' was denied in the XmlDataSource with ID 'myRssFeed' because of security settings


    Is there some setting in IIS7 manager that I need to configure to make this work?

    Thanks in advance.
     
    Last edited by a moderator: Oct 14, 2015
  2. Ray

    Ray

    What is the full and complete and exact error message? Also provide the stack trace that may have come with this.
     
  3. Guest

    Guest Guest

    There is no exception stack trace. It is not a full page default exception since this is an XMLDataSource asp.net control. The error message that I posted above is all I have.

    Are you restricting access to other sites from websites hosted on Winhost?

    The feed I am trying to access is the following:
    http://www.realestatejournal.com/newsfeed/rss/rej_frontpage.xml


    <asp:XmlDataSource ID="myRssFeed" runat="server" EnableCaching="false" DataFile="<%$ AppSettings:RealEstateRssFeed %>"
    XPath="/rss/channel/item" />

    This above XMLDataSource feeds into a repeater control which displays rss items.

    The error once again is just this:

    Access to the URL '/newsfeed/rss/rej_frontpage.xml' was denied in the XmlDataSource with ID 'myRssFeed' because of security settings.
     
    Last edited by a moderator: Oct 14, 2015
  4. Ray

    Ray

    Try increasing the trust mode to either High or Full. By default it is set to Medium.
     
  5. Guest

    Guest Guest

    It is already at Full trust. Any more ideas?
     
  6. Ray

    Ray

    I'm not getting any errors when I click on "http://www.realestatejournal.com/new..._frontpage.xml". It simply redirects me to http://online.wsj.com/xml/rss/3_7400.xml

    Can you give me detailed instructions on how I can replicate this error on my end?
     

Share This Page