Problem with website admin tool

Discussion in 'Databases' started by wsyeager36, Jan 31, 2012.

  1. I had a sql server express db managing my roles, etc. I need to change the data source from sql express to sql server because my hosting provider does not have sql express.

    I want to make the changes locally first to ensure everything is working before I publish the database.

    I successfully ran the configuration tool creating a new database with all the membership tables.

    The new connectionstring inside my web.config file is below. Even though the password is shown here with the asterisks, I can assure you that it is spelled out correctly. I just obviously substiture it here for security reasons.
    Data Source=bill-pc;Initial Catalog=ApplicationServices;Persist Security Info=True;User ID=wyeager;Password=*********

    I then went into my Visual Studio 2010 project and deleted the sql server express db inside my app_data folder.

    I then went into IIS 7 and added the above connectionstring to the connectionstrings. However, when I add the connectionstring, it always substitutes the asterisks for the password.

    I believe the below error is because the configuration tool cannot successfully read the password for the connectionstring.

    I then ran the configuration tool for my project and now gives me the below error. I know it seems to be reading from the IIS connectionstring setting, because before, I didn't have any userid in there and just said "failed for user """. I added my userid and password and got the below error.

    How can I successfully connect the membership tool with my new database?

    There is a problem with your selected data store. This can be caused by an
    invalid server name or credentials, or by insufficient permission. It can also
    be caused by the role manager feature not being enabled. Click the button below
    to be redirected to a page where you can choose a new data store.

    The following message may help in
    diagnosing the problem: Login failed for user 'wyeager'.
  2. All I'm trying to do is to use the website admin tool in conjunction with my new database.

    As I've described in my post, it appears that the tool cannot read the password in the IIS connectionstring setting (which is where it reads from) because the password always contains asterisks even though when I type it in, it formats it to the asterisks.

    IN order to use the admin tool, I must update IIS to contain the new connectionstring because that's where the admin tool reads the connectionstring from.

    How can I enter the password without the asterisks?

    Surely someone must have changed their membership db from sqlexpress to sqlserver and get the website admin tool to read now from sql server.
  3. If I don't get a response back from an Admin of this site in order to resolve this issue, I'm going to have to close my account and go to a hosting site that supports sql express.

    I have tried everything in creation I can think of to resolve this issue along with the below thread. I know I'm not going to be able to change the machine.config file on your servers to help resolve the issue.

    I have also checked in this forum in regards to this issue, but nobody has explained how they were able to get the WSAT (web site administration tool) to work with the sql server database that now contains the membership data.

    Looking for a response... thanks...
  4. Last edited by a moderator: Oct 14, 2015

Share This Page