Joomla site deployment

Discussion in 'Third-party applications' started by mjmcelravy, Mar 29, 2011.

  1. I am migrating a Joomla site from another host to Winhost. I have the site working properly in a folder, and I have that folder set up as an Application Starting point in Control Panel.

    Is there a way to automatically run the code in that folder? I have tried the IIS7 URL rewrite described in and this allows the home page to display properly, but any clicks to other pages in the site generate "link broken" errors.

    Is there a better way to force a joomla application to use that folder or would it be better to just move the application to the root folder?
    Last edited by a moderator: Oct 14, 2015
  2. Ray


    If you do not have any other application running, then I suggest you move the Joomla application to the root.
  3. Thanks, will do. I appreciate your help and the quick response.
  4. Joomla deployment

    Two more questions related to my deployment of a Joomla app and installing it in root.

    1. Would the creation of a virtual directory solve the problem?
    2. I currently do not seem to have authority to save a file in root? Can I change that using IIS7?

  5. Ray


    No. Your root is already set as an application virtual directory.

    What do you mean? You should already have full read and write permission to your root and all the files and folders within it. Are you having problems with the FTP? If you are send us the FTP log.
  6. Joomla deployment

    Here is a section from the FTP log:

    Command: STOR testfile.txt
    Response: 550 Access is denied.
    Error: Critical file transfer error
  7. Ray


    I'll actually need the full ftp log so I can investigate it further.
  8. Joomla deployment

    I am attaching the FTP log.

    Attached Files:

  9. Ray


    Typically from what I have seen passive mode tends to be very temperamental.

    I suggest you try changing the connection mode from Passive Mode to active port mode.

    Now if you have any firewalls, proxy's, NAT, and even a router, I suggest you try bypassing that and connect directly to the Internet.
  10. That worked. Thanks again for your help.

Share This Page