Installing Umbraco

Discussion in 'Third-party applications' started by amhed, Apr 1, 2010.

  1. Hey guys, has anyone installed umbraco here? I'm having some trouble uploading a site that was developed in Umbraco. It runs OK on my Windows 7/IIS 7 development PC, but it doesn't work once I upload to the site.

    I even tried uploading a fresh copy so I can run the Web Install, but I keep getting "An ASP.NET setting has been detected that does not apply in Integrated managed pipeline mode."

    Any thoughts?
  2. Ray


    What is the error message you are getting? Do you have a URL for us to use so we can replicate the error on our end?
  3. Last edited by a moderator: Oct 14, 2015
  4. Ray


    Try logging into your Winhost control panel. Click on the tab marked Sites. Go to your site and click on the Manage link. This will take you to the Site Info Manager for that site. Click on the button marked Integrated or Classic Mode. Click on the drop down list and choose Classic mode for your pipeline. You may need to recycle your application after this.
  5. I tried doing that but I get an error with ASPX 3.5 extensions. Click on the link again so you can see it.
  6. Ray


    --<add assembly="System.Web.Extensions, Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" />

    This error means that your application is setup to look for AJAX version 1.0.6 on our server. We only have AJAX version 3.5 installed.

    You have two options.

    1. Update your code to use AJAX version 3.5. Try looking at this kb article.

    2. Upload the AJAX version 1.0.6 component in your applications Bin folder and have your application reference it from there.
    Last edited by a moderator: Oct 14, 2015
  7. OK, changed al references to

    Now I get an error, "Request Failed"

    <add name="UmbracoRoleProvider" type="umbraco.providers.members.UmbracoRoleProvider" />
  8. Ray


    Try "UsersMembershipProvider" as your roles provider name.

    You may also need to update the type to..

  9. I got the latest web.config for ASP.NET 3.5 from the Umbraco website and it works fine now.

    I just need write access for my folder so I can run the instalation wizard.
  10. Ray


    By default ASPNet IUSR should already have full Read and write permission to the root and all the contents inside it.
  11. Last edited by a moderator: Oct 14, 2015

Share This Page