HTTP Error 500.19 - Internal Server Error

Discussion in 'Site Programming, Development and Design' started by jdelgado, Mar 8, 2010.

  1. Hi,

    I am getting an error when I added the sessionState to the web.config file of my web application I have look and I cannot find what is wrong it with:

    < sessionState
    allowCustomSqlDatabase = "true"
    sqlConnectionString="data;database=XXXX;user id=XXX_user;password=XXX"
    timeout="15" />

    The error description is "Configuration file is not well-formed XML"


    Julio D
    Last edited by a moderator: Oct 14, 2015
  2. Ray


    Instead of coding it, try setting it on IIS 7 Manager. Use IIS 7 Manager to connect to the server.

    Once connected you'll probably need to setup the correct connection string. Go to the modulle Connection String and you'll see two connection string name. One is LocalSQLServer and the the other SiteSQLServer. You can also define your own if you want.
    Once you setup the connection string to connect to your database, navigate to the module Session State.
    Click on the bubble SQL Server and you will get a drop down option to choose what connection string name to use. By default you should have the names 'LocalSQLServer' and SiteSQLServer. If you do not see it don't panick you probably deleted it by accident. Just go back to the module Connection String and create it. And any custom connection string name you create should also be on the drop down list.
    Last edited by a moderator: Oct 14, 2015
  3. Thanks Ray that is what I did and it works I downloaded IIS 7 and change the configuration there.

    The end results was:

    <sessionState allowCustomSqlDatabase="true" cookieless="UseCookies" mode="SQLServer" sqlCommandTimeout="1800" sqlConnectionString="data Source=XXXX;database=XXXX;user id=XXXXX;password=XXXX" timeout="30" />

Share This Page