ftp over ssl

Discussion in 'FTP' started by FishLazyWaters, Feb 4, 2011.

  1. I'm trying to make sure that I am using ftp over ssl.

    I have been using Filezilla. There are two ways to connect:

    1) with the "Open Site Manager" button as described in your post:http://support.Winhost.com/KB/a666/how-to-set-up-filezilla-to-use-ftp-over-ssl.aspx

    2) Manually enter the Host,username, and password on Filezilla's log in bar.

    #1 does not work no matter what I try (I've been trying for more than an hour) and I get :
    Status: Connection established, waiting for welcome message...
    Response: 220-Microsoft FTP Service
    Response: 220 Winhost.com FTP
    Command: AUTH TLS
    Response: 234 AUTH command ok. Expecting TLS Negotiation.
    Status: Initializing TLS...
    Error: Connection timed out
    Error: Could not connect to server

    #2 works but I am not sure that it logs in via ssl

    When I use #2 part of the message I get includes:
    Response: 211-Extended features supported:
    Response: LANG EN*
    Response: UTF8
    Response: AUTH TLS;TLS-C;SSL;TLS-P;

    Well this says that these features are supported but it doesn't say that they are in use.

    Does anyone know how to tell if you are actually connected via ssl?

    Thanks in advance.
    Last edited by a moderator: Oct 14, 2015
  2. Ray


    What steps did you take to make #2 work? FTP over SSL is supported on our web server.
  3. I don't remember I've been using it that way for, I think, more than four years (with Winhost and others). Never have any problems with #2 (except I don't know if it is secure).

    Method #1 seems very stuborn. I've tried every combination that I can think of by following the given kb post and other stuff.

    But I don't care about #1 only about a secure link.
    Last edited by a moderator: Oct 14, 2015
  4. The simplest solution is probably to try one of the other free ftp clients.

    Doing that might also flush out the problem I'm having with filezilla.
  5. Ray


    It looks like with step # 2 you are connecting to the web server simply by FTP and not with FTP over SSL. For now as a test, try bypassing your firewall and router and connect directly to the Internet.
  6. Thanks,

    I just tried turning off my fire wall.

    I also tried SmartFtp.

    I also tried both of my sites with the same result (www.springperi.com and www.subtopic.cc)

    And, I just submitted a support ticket.
  7. Ray


    I just tested it and FTP over SSL worked for me. I tested account "springperi.com" using FileZilla. Make sure you choose FTPES - FTP over explicit TLS/SSL for the "Server Type". Also make sure you choose Normal for the "Logon Type".
  8. Thanks :),

    No success.

    I've tried all possible combinations on two different computers. The only common piece of hardward is my wireless connection (Sprint). I'll have to wait until next week when I can try a different connection.

    Support sent me a screen shot of how FileZilla's "Site Manager" should look and I had tried that 22,010 times. They also connected ok.

    Did you connect from a network outside of Winhost's LAN?

    Machine 1: Windows 7, Machine 2: XP; Two different versions of FileZilla and SmartFTP
    Last edited by a moderator: Oct 14, 2015
  9. Ray


    Actually yes. Our office LAN is completely separate from the servers network. Obviously this is to make it more secure for the servers.
  10. Well, I got through one time.

    I can't dublicate it but it happened after I turned off my "home website" via IIS 7. (Just thought about it.) I'm not really convinced that this is related because I can't log on anymore...

    Before I could get on that once I got a "Unknown certificate" message box. When I accepted it I got on.
  11. Ray


    It definitely sounds like a network issue from your end. Try dropping that site profile from your FileZilla or FTP client and recreate it again. Did you try connect via FTP over SSL using another network? Bear in mind that updates to firewalls and routers can occur at any time. And often it can change the rules or how it handles certain protocols, often the best test is to connect using another network completely.
  12. I got it to work.

    What I had to do was to uninstall my security software on an old computer.

    (Even if I turned off the firewall it didn't work.)

    Maybe I can find a free firewall that allows me to turn it off for a quick shot.
  13. I've been using Microsoft Security Essentials and it really isn't a bad product. I've even caught a few issues with my machine which other virus protection apps did not catch.

    I like that you can throttle the scanning CPU usage, so it's less intrusive than a lot of the other ones.
  14. Ray


    Also if you are behind a corporate firewall or proxy and simply cannot open the network, you can try an online file transfer web site that can do it for you. Since it uses http to upload your files then connects to the remote server via FTP its a good way to bypass most local area network restrictions.


Share This Page