Forcing WordPress to use SSL

Discussion in 'Site Programming, Development and Design' started by mestrupp, Oct 20, 2014.

  1. Is there a way to force WordPress to use my SSL certificate when it loads? I've been experimenting with various WordPress plugins that are designed to do this, but so far, I've had no luck. The SSL certificate works fine (when I enter it manually, it loads the pages correctly). Any thoughts?
  2. Elshadriel

    Elshadriel Winhost Staff

    You can try using URL Rewrite. More information in this post.
    Last edited by a moderator: Oct 14, 2015
  3. Have you tried making the URL https:// in

    Settings > General > WordPress Address (URL)
    Settings > General > Site Address (URL)

    ComputerMan and Elshadriel like this.
  4. Just as a quick followup: after playing around with this a bit more, I was able to get it to work without having to resort to using the IIS Manager (which I'm not sure would work anyway) or using URL Rewrite.

    Here's what I did:

    I used Michael's tip about adding https:// to the two settings in WordPress.
    I also downloaded and installed the WordPress HTTP SSL plug in which helped.

    Note that for each page, I specifically checked the checkbox for SSL encyryption which is installed by the HTTP SSL plugin.
    I also made sure that all of my internal links on pages in my site (to images and whatnot) used HTTPS which resulted in eliminated the annoying "Unsecure Content" warnings from Chrome and Firefox.

    Thanks again for all of your help!
    ComputerMan likes this.
  5. Cool, thanks for posting your solution.

Share This Page