Error getting SqlServer CE running on my site: "Unable to load one or more of the requested types."

Discussion in 'General troubleshooting' started by JeffG, Feb 9, 2014.

  1. My site works perfectly locally. When I upload it to the server, I get the following error:

    I only get the error on the page that tries to use the SqlServer CE database. If you wish, you can compare it to one that is working:


    The CircusReviews page has an EntityDataSource.

    How do I get this working?


    P.S. It seems I can only go as high as .NET 4.0 on your site, yet your web page says I can get up to 4.5.x. Is there some kind of change I need to make to get access to the higher versions of .NET?
  2. rum

    rum Winhost Staff

    It looks like the SQL Server CE assemblies are missing from the bin folder of your web application. You need to either add deployable dependencies for sql ce when deploying your project with Visual Studio or Web Matrix, or upload those components (DLLs) to the bin folder of your web application. Please see the following post that shows how to do so in Visual Studio.
    Michael likes this.
  3. Unfortunately, that solution requires a Web Application project; I'm using a Web Site project. I suppose I could always convert it from one to the other, but mightn't there be an easier way?

    Currently, I have the following assemblies being deployed from my bin directory:

    AjaxControlToolKit, 3, 5, 50401, 0
    AjaxMin, 5, 7, 5124, 21494
    BlogEngine.Core, 1, 6, 0, 0 (really don't need this anymore; I probably should delete it)
    EntityFramework, 6, 0, 21211, 0
    EntityFramework.SqlServer, 6, 0, 21211, 0
    EntityFramework,SqlServerCompact, 6, 0, 21211, 0
    IronRuby, 1, 1, 3, 0 (Never used this. Not sure why I have this here. I probably should delete it.)
    IronRuby.Libraries, 1, 1, 3, 0 (Ditto)
    Jurassic, 2, 1, 0, 0 (Ditto)
    Log4net, 1, 2, 13, 0
    System.Data, 4, 0, 30319, 1
    System.Data.Entity.Design, 4, 0, 30319, 1
    System.Data.SqlServerCe, 4, 0, 8876, 1
    System.Data.SqlServerCe.Entity, 4, 0, 8876, 1
    System.Web.Ajax, 3, 0, 31106, 0​

    So is there anything I'm missing here?

  4. ComputerMan

    ComputerMan Winhost Staff

    What did you use to create the web site? If you used Visual Studio what version did you use?

    When you use Visual Studio you need to make sure you add(include) the assemblies when web deploying. This will make sure everything your project requires gets deployed onto the server.
  5. I've actually since "solved" the problem.

    Well, not solved so much as "avoided". It occurred to me that I didn't really need the EntityFramework to access my data, just SqlServerCE. So I nuked the references to the EntityFramework, hooked my data controls to the raw SqlServerCE connection, and everything's working fine now.

    (I did, however, convert my project into a Web Application.)

    Thanks anyway! :)


    P.S. Nobody answered my question about how I could get moved to a machine that supported .NET 4.5....
  6. Elshadriel

    Elshadriel Winhost Staff

    Hi Jeff,

    You just need to open up a support ticket, and we'll move your site for you.
  7. What would be the ramifications of that? Would my site, written for 4.0, work as is? Would my data connection string to my database remain the same?
  8. Elshadriel

    Elshadriel Winhost Staff

    I can't comment if your site will work, but the database connection string will remain the same.

Share This Page