DNN Install - Error

Discussion in 'Third-party applications' started by Bobter, Oct 26, 2009.

  1. Hi,

    I followed your instructions at


    for a DNN install and I am gettin this error from the Install/InstallWizard.aspx page and the site doesnt install -

    System.Security.SecurityException: Request for ConfigurationPermission failed while attempting to access configuration section 'system.web/deployment'. To allow all callers to access the data for this section, set section attribute 'requirePermission' equal 'false' in the configuration file where this section is declared. ---> System.Security.SecurityException: Request for the permission of type 'System.Configuration.ConfigurationPermission, System.Configuration, Version=, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a' failed. at System.Security.CodeAccessSecurityEngine.Check(Object demand, StackCrawlMark& stackMark, Boolean isPermSet) at System.Security.CodeAccessPermission.Demand() at System.Configuration.BaseConfigurationRecord.CheckPermissionAllowed(String configKey, Boolean requirePermission, Boolean isTrustedWithoutAptca) The action that failed was: Demand The type of the first permission that failed was: System.Configuration.ConfigurationPermission The first permission that failed was: The demand was for: The granted set of the failing assembly was: The assembly or AppDomain that failed was: System.Web.Extensions, Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35 The method that caused the failure was: Boolean GetRetailFromConfig() The Zone of the assembly that failed was: MyComputer The Url of the assembly that failed was: file:///E:/web/livetime/bin/system.web.extensions.DLL --- End of inner exception stack trace --- at System.Configuration.BaseConfigurationRecord.CheckPermissionAllowed(String configKey, Boolean requirePermission, Boolean isTrustedWithoutAptca) at System.Configuration.BaseConfigurationRecord.GetSectionRecursive(String configKey, Boolean getLkg, Boolean checkPermission, Boolean getRuntimeObject, Boolean requestIsHere, Object& result, Object& resultRuntimeObject) at System.Configuration.BaseConfigurationRecord.GetSection(String configKey, Boolean getLkg, Boolean checkPermission) at System.Configuration.BaseConfigurationRecord.GetSection(String configKey) at System.Web.HttpContext.GetSection(String sectionName) at System.Web.Configuration.HttpConfigurationSystem.GetSection(String sectionName) at System.Web.Configuration.WebConfigurationManager.GetSection(String sectionName) at System.Web.UI.DeploymentSectionCache.GetRetailFromConfig() at System.Web.UI.DeploymentSectionCache.get_Retail() at System.Web.UI.ScriptReference.IsDebuggingEnabled(ScriptManager scriptManager) at System.Web.UI.ScriptReference.ShouldUseDebugScript(String releaseName, Assembly assembly, ScriptManager scriptManager) at System.Web.UI.ScriptReference.GetResourceName(String releaseName, Assembly assembly, ScriptManager scriptManager) at System.Web.UI.ScriptReference.GetUrlFromName(ScriptManager scriptManager, IControl scriptManagerControl, Boolean zip) at System.Web.UI.ScriptReference.GetUrl(ScriptManager scriptManager, IControl scriptManagerControl, Boolean zip) at System.Web.UI.ScriptManager.RegisterScripts() at System.Web.UI.ScriptManager.OnPagePreRenderComplete(Object sender, EventArgs e) at System.Web.UI.Page.OnPreRenderComplete(EventArgs e) at System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint) The Zone of the assembly that failed was: MyComputer

    Any ideas why it doesnt work?
    Last edited by a moderator: Oct 14, 2015
  2. Ray


    Try increasing the trust level on your application to Full. The element should be in your web.config file.

    <trust level="Full|High|Medium|Low|Minimal" />
  3. ok so I am getting this error now instead of the connection string error and I changes the walue to Full without any changes.
  4. Ray


    Whats the error you are getting.
  5. Hi - I am having a similar issue. I have moved a working DNN site from a different host (was IIS6) to Winhost. I copied the files over, restored the database, changed the portalalias in the database to the temp URL (I haven't moved the DNS yet), and I get this:


    I tried changing trust to full just to see, but I still get the error above.

    Also, requirePermission is already false in web.config (snippet below)

    <sectionGroup name="dotnetnuke">
    <!-- the requirePermission attribute will cause a syntax warning - please ignore - it is required for Medium Trust support-->
    <section name="data" requirePermission="false" type="DotNetNuke.Framework.Providers.ProviderConfigurationHandler, DotNetNuke" />
    <section name="logging" requirePermission="false" type="DotNetNuke.Framework.Providers.ProviderConfigurationHandler, DotNetNuke" />
    <section name="scheduling" requirePermission="false" type="DotNetNuke.Framework.Providers.ProviderConfigurationHandler, DotNetNuke" />
    <section name="htmlEditor" requirePermission="false" type="DotNetNuke.Framework.Providers.ProviderConfigurationHandler, DotNetNuke" />
    <section name="navigationControl" requirePermission="false" type="DotNetNuke.Framework.Providers.ProviderConfigurationHandler, DotNetNuke" />
    <section name="searchIndex" requirePermission="false" type="DotNetNuke.Framework.Providers.ProviderConfigurationHandler, DotNetNuke" />
    <section name="searchDataStore" requirePermission="false" type="DotNetNuke.Framework.Providers.ProviderConfigurationHandler, DotNetNuke" />
    <section name="friendlyUrl" requirePermission="false" type="DotNetNuke.Framework.Providers.ProviderConfigurationHandler, DotNetNuke" />
    <section name="caching" requirePermission="false" type="DotNetNuke.Framework.Providers.ProviderConfigurationHandler, DotNetNuke" />
    <section name="authentication" requirePermission="false" type="DotNetNuke.Framework.Providers.ProviderConfigurationHandler, DotNetNuke" />
    <section name="members" requirePermission="false" type="DotNetNuke.Framework.Providers.ProviderConfigurationHandler, DotNetNuke" />
    <section name="roles" requirePermission="false" type="DotNetNuke.Framework.Providers.ProviderConfigurationHandler, DotNetNuke" />
    <section name="profiles" requirePermission="false" type="DotNetNuke.Framework.Providers.ProviderConfigurationHandler, DotNetNuke" />

    You can see it here:


    Any help you can give me would be greatly appreciated.

    Thanks - Harriet
    Last edited by a moderator: Oct 14, 2015
  6. Ray


    It appears to be failing in this part "'system.web deployment'. Can you check what AJAX version your application is trying to load?
  7. Thanks for the response, I'm sorry can you be more specific (I'm not sure how to answer your question). Is this something that would be in web.config? I did see a post related to changing the System.Web.Extension versions:

    > Open the Web.Config and replace ALL instances of "1.0.61025.0" with "" (Save and Close) - on the DNN site

    I tried this and then I got that basic "object not set to an instance" error.

    My web config does have: Version=1.0.61025.0 for the version - is that not right?

    Just let me know where to find what you're asking me for - Harriet
  8. Ray


    Try looking at this kb article about the version of AJAX installed on our GAC.


    If you are getting a message "object not set to an instance" error... This is different from the error you are getting before.

    From what I have seen with DNN this error usually means that you have not setup the DNN schema on the SQL server. Have you ran a DNN sql script against the SQL server you are connecting to? If you are sure that all the DNN objects and tables that DNN calls on are on the SQL server, then make sure that the provider name DNN is using is setup to use the correct connection string.
    Last edited by a moderator: Oct 14, 2015
  9. >replace ALL instances of "1.0.61025.0" with ""

    I did this again, and got the "Object+reference+not+set+to+an+instance+of+an+object" error.

    Then I found this post that said:

    > Do you still have a system.web.extensions.dll in the BIN folder of your website? If you have .net 3.5sp1 you won't need that file in the BIN folder.

    So I deleted the .dll - and now the site actually comes up! Now I'm getting another "Object reference not set to an instance of an object." error so I'll dig into that. Just thought I'd keep documenting it here in case it will help anyone else.

  10. Amazingly after I made the last post I started just clicking through the site, and the error went away. The solution for me seems to be:

    1. change the version from "1.0.61025.0" to ""

    2. delete the system.web.extensions.dll in the bin folder.

Share This Page