Could not load file or assembly 'System.ServiceModel.DomainServices.Hosting

Discussion in 'General troubleshooting' started by stevozilik, Dec 16, 2010.

  1. Hi guys,

    I've put my website on your hosting, loaded up database, opened the secondary adress and this is what I get:

    Could not load file or assembly 'System.ServiceModel.DomainServices.Hosting, Version=, Culture=neutral, PublicKeyToken=31bf3856ad364e35' or one of its dependencies. The system cannot find the file specified.

    Btw I'm using SL4 with Ria services

    any ideas?

    Best Regards,
  2. Ray


    Are you sure you uploaded all the required files/components/assemblies in your applications Bin folder?
  3. This should be comming from GAC in

    C:\Program Files (x86)\Microsoft SDKs\RIA Services\v1.0\Libraries\Server\System.ServiceModel.DomainServices.Hosting.dll

    if you had Ria services installed. Am I supposed to provide all the RIA dll's by myseft?
  4. Ok got rid of that one by providing the required dlls.

    now another one, which worries me more:

    Security Exception
    Description: The application attempted to perform an operation not allowed by the security policy. To grant this application the required permission please contact your system administrator or change the application's trust level in the configuration file.

    How can I find out what the security exception is about?
  5. Ray


    Last edited by a moderator: Oct 14, 2015
  6. cool that worked.

    another one - RIA related: Remote server not found. I suppose I need to change the server address on client...
  7. Ray


    There is not enough information to really answer your question. What the full error and how can we replicate it on our end.
  8. sorry here is a bit more. The default WebDomainClient address generated by Ria (on client side) is:

    new WebDomainClient<IFrameworkDomainServiceContract>(new Uri("WebLiveTiming-Web-Services-FrameworkDomainService.svc", UriKind.Relative)))

    I need to obviously change it to point to the server. What to prefex it with?

    I have tried:

    where is my web adress and how it's saying:

    Load operation failed for query 'GetDomains'. An error occurred while trying to make a request to URI ''. This could be due to attempting to access a service in a cross-domain way without a proper cross-domain policy in place, or a policy that is unsuitable for SOAP services. You may need to contact the owner of the service to publish a cross-domain policy file and to ensure it allows SOAP-related HTTP headers to be sent. This error may also be caused by using internal types in the web service proxy without using the InternalsVisibleToAttribute attribute. Please see the inner exception for more details.
    Last edited by a moderator: Oct 14, 2015
  9. Ray


    Last edited by a moderator: Oct 14, 2015
  10. didn't help, got the original:

    Invoke operation 'ProcessLog' failed. The remote server returned an error: NotFound.


    tried to put clientaccesspolicy.xml and crossdomain.xml into app root. When the .xap is requesting those, it can't find them (fiddler), even thought they are there...

    404 HTTP /clientaccesspolicy.xml 5,201 private text/html; charset=utf-8 iexplore:4796
    404 HTTP /crossdomain.xml 5,187 private text/html; charset=utf-8 iexplore:4796
    Last edited by a moderator: Oct 14, 2015
  11. Ray


    I am getting an error with this line in it when I pull up

    An error occurred while trying to make a request to URI '

    What are your http bindings look like?
    Last edited by a moderator: Oct 14, 2015
  12. Last edited by a moderator: Oct 14, 2015
  13. Thanks for posting that follow-up. It will help others who run into the same issue.

Share This Page