- Admin pages blank.

Discussion in 'Third-party applications' started by Greg, Jan 22, 2015.

  1. This is a weird one.

    It _was_ working. I used the one click tool for the app, no problem, working great.

    Uploaded a new BlogEngine.Net.dll with an additional widget included (and associated ascx files in the widget directory of course).
    Uploaded a new template.

    And it still worked fine and dandy.

    Then starting yesterday, for no apparent reason as far as I can tell, the /admin pages now come back blank.

    I even copied all the /admin files down to my local machine and the work great against localhost.

    What the hey!?

    Any help here would be appreciated.

  2. ComputerMan

    ComputerMan Winhost Staff

    Can you run Debug tools like Google Chrome's Developer Tools against the page to see if you can find any helpful error messages? If you do get an error message please provide it to us.
  3. Hey I got something for ya. :)

    Navigated to
    Uncaught ReferenceError: jQuery is not defined
    (anonymous function)

    In jQuery? Weird, I haven't done anything there with that...hmmm. Does that imply I am missing my jquery js lib or some declaration somewhere? This is not something I messed with.

    I have the application source and any pointers would be helpful. I'll take a look myself.
  4. ComputerMan

    ComputerMan Winhost Staff

    Are you using Internet Explorer?

    I visited the link and I saw the login page for your admin section (its not blank). Maybe the issue is coming from the web browser? Try using a different web browser like Google Chrome or Firefox.
  5. The login page is actually a re-direct for non-logged in users. It isn't even in the "admin" directory and therefore doesn't have the same restrictions.

    I'm at a loss here. I think my only option is to flatten the site and re-install Blogengine.

  6. FredC

    FredC Winhost Staff

    greg. not sure i understand the problem.

    I went to using both IE, FF and Chrome and not getting any error you said.
  7. FredC

    FredC Winhost Staff

    ic.. i can really tell then.. can you setup a login for me and private message to me?
  8. FredC

    FredC Winhost Staff

    i was able to replicate. I copy your site to my test account on IIS7 and I got the same problem.

    I did some research and it seems like several people have seen this problem after upgrade but unfortunately no one has any solution.

    I would try upload the files again and see if you missed any files.
  9. ComputerMan

    ComputerMan Winhost Staff

    I was able to find this web page article regarding your issue here:

    Perhaps your admin folder's web.config file is inheriting settings from the root's web.config that might be causing the issue for your admin section.
    Michael likes this.
  10. Well I tried a lot of things and nothing fixed it.

    So....I just copied my blog posts down local and blew away the entire app and re-installed. Voila fixed.

    Disconcerting that I don't know what it was - but at least it is operational now.
    ComputerMan likes this.
  11. ComputerMan

    ComputerMan Winhost Staff

    Thanks for the follow up and I'm glad you where able to resolve your issue.

Share This Page